Laboratorios Visto: 112

Laboratorio VPN L2TP/IPSEC para clientes Windows

 

 

Paso 1:
Configuración del Servidor L2TP
 

En esta ocasión vamos a configurar un L2TP/IPsec server en nuestro MikroTik, para ello volvemos a la parte PPP, una vez allí nos dirigimos a la pestaña Interface y luego le damos al botón L2TP Server , se nos abrirá una nueva ventana donde vamos a configurar los siguientes campos: 

 

PPP / Interfaces / L2TP Server

 

 

 

 

 

Creación del Servidor 

/interface l2tp-server server set enabled=yes use-ipsec=required ipsec-secret=mySecret default-profile=default

 

 

Paso 2:
Creación de Usuarios VPN L2TP

Una vez hecho el paso anterior, nos dirijimos a la pestaña Secrets donde crearemos nuestros usuarios vpn, en este apartado, deberemos configurar:


Name = Nombre de usuario vpn
Password = Contraseña para el usuario vpn
Service = Servicio afectado al usuario
Profile  = Perfil de usuario vpn
Local Address =Dirección ip para el tunel, ip de mk 
Remote Address =  Dirección ip para el tunel, ip del cliente

PPP/ Secrets

 

 

Creación del Usuario VPN 

/ppp secrets add name=usuario_VPN service=l2tp password=123 local-address=10.0.0.1 remote-address=10.0.0.2 routes="192.168.10.0/24"

 

 

Paso 3:

Permitimos trafico VPN en el Firewall

Ahora nos dirigimos a la parte de firewall y agregamos nuestra regla de
input para aceptar el trafico entrante de los siguientes puertos:

- UPD: 1701
- UDP: 500
- UDP: 4500

 

IP / Firewall / Filter Rules

 

 

Creación de reglas de Firewall

/ip firewall filter add chain=input protocol=udp port=1701,500,4500
/ip firewall filter add chain=input protocol=ipsec-esp

 

 

 

Paso 4:
Configuración del Cliente L2TP Windows

Ahora vamos a configurar nuestro cliente Windows 10, para ello nos
dirigimos Configuraciones y luego a Red Internet, una vez allí seleccionamos VPN y
damos click a Agregar conexión VPN. Ver imagen a la derecha.

Botón: Agregar VPN

 

 

 

 

 

 

 

Paso 5:
Configuración del Cliente L2TP Windows

Una vez hecho el paso anterior nos saldrá una venta para la configuración
de nuestro cliente L2TP/IPsec, Nombre de Conexión: será un nombre de su gusta
para identificar su vpn.

Nombre de servidor o dirección: aquí pondremos nuestro
DDNS o IP publica de nuestro server luego seleccionamos el tipo de VPN, y por
ultimo en Clave Previamente compartida: colocamos nuestro Secret IPsec, una vez
hecho todo esto damos click al botón Guardar. Ver imagen 2.12.

 

Nombre de servidor o dirección = IP o  DDNS de nuestro Mikrotik
Tipo de VPN = L2TP/IPSEC con clave previamente compartida
Clave previamente compartida = Clave de IPSEC (PSK)
Tipo de información de inicio de sesión = Nombre de usuario y contraseña
Nombre de usuario (Opcional) = Usuario de VPN
Contraseña (Opcional) = Clave de usuario VPN